Pages

Wednesday, March 31, 2010

Tuning HSRP - GNS3


configure PC, R1, R2 and R4 as below
PC
PC(config)#no ip routing
PC(config)#int fa 0/0
PC(config-if)#ip add 10.1.1.10 255.255.255.0
PC(config-if)#no shut

R1
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip add 10.1.1.1 255.255.255.0
R1(config-if)#no shut

R1(config)#int serial 0/0
R1(config-if)#ip add 172.16.1.2 255.255.255.252
R1(config-if)#clock rate 64000
R1(config-if)#no shut

R1(config)#router eigrp 1
R1(config-router)#no auto-summary
R1(config-router)#net 0.0.0.0
R2
R2(config)#int fa 0/0
R2(config-if)#ip add 10.1.1.2 255.255.255.0
R2(config-if)#no shut

R2(config)#int ser 0/0
R2(config-if)#ip add 172.16.2.2 255.255.255.252
R2(config-if)#clock rate 64000
R2(config-if)#no shut

R2(config)#router eigrp 1
R2(config-router)#no auto-summary
R2(config-router)#net 0.0.0.0
R4
R4(config)#int ser 0/0
R4(config-if)#ip add 172.16.1.1 255.255.255.252
R4(config-if)#no shut

R4(config-if)#int ser 0/1
R4(config-if)#ip add 172.16.2.1 255.255.255.252
R4(config-if)#no shut

R4(config-if)#int lo 0
R4(config-if)#ip add 192.168.1.1 255.255.255.255
R4(config-if)#

R4(config)#router eigrp 1
R4(config-router)#no auto-summary
R4(config-router)#net 0.0.0.0

make sure PC can ping all the interfaces on R1, R2 and R4 !! if can’t, troubleshoot it accordingly

create standby interface for PC and point the PC’s gateway to this address
R1(config)#interface fastEthernet 0/0
R1(config-if)#standby 1 ip 10.1.1.99
R1(config-if)#standby 1 priority 150
done for R1. 3rd line is to set R1 to have the higher priority, default value is 100. Configure same for R2 accept the 3rd line, leave default value for R2
R2(config)#interface fastEthernet 0/0
R2(config-if)#standby 1 ip 10.1.1.99

configure default-gateway for PC
PC(config)#ip default-gateway 10.1.1.99

let’s verify our configuration are working correctly
1st let check the prioritytraceroute from PC to 172.16.2.1  result should showing as below, since we set Interface 10.1.1.1 to have the higher priority
PC#traceroute 172.16.2.1
1  10.1.1.1 20 msec 16 msec
  2 172.16.1.1 40 msec 100 msec *
R1#sh stan
FastEthernet0/0 - Group 1
  State is Active
    17 state changes, last state change 00:00:47
  Virtual IP address is 10.1.1.99
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.224 secs
  Preemption disabled
  Active router is local
  Standby router is 10.1.1.2, priority 100 (expires in 8.972 sec)
  Priority 150 (configured 150)
  IP redundancy name is "hsrp-Fa0/0-1" (default)

then make sure failover are working fine, do continuous ping to 172.16.2.1, then shutdown Int Fa 0/0 on R1, Fa 0/0 on R2 (10.1.1.2) should be the active standby router now, there should be about 10 second of down time. that’s is the default hold time before interface considered as death. later we’ll tune this value to make it shorter
Protocol [ip]:
Target IP address: 172.16.2.1
Repeat count [5]: 99999
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 99999, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:
.!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!.....!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!.
Success rate is 93 percent (104/111), round-trip min/avg/max = 24/60/100 ms
traceroute again to verify the path is thru 10.1.1.2
1 10.1.1.2 24 msec 8 msec 16 msec
2 172.16.2.1 52 msec 64 msec *

bring up again the 10.1.1.1 interface, then issue command show standby on R1, notice that 10.1.1.2 still the active standby router even we already set 10.1.1.1 to have the higher priority
R1#show standby
FastEthernet0/0 - Group 1
  State is Listen
    18 state changes, last state change 00:04:12
  Virtual IP address is 10.1.1.99
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (default)
  Hello time 3 sec, hold time 10 sec
  Preemption disabled
  Active router is 10.1.1.2, priority 100 (expires in 9.888 sec)
  Standby router is unknown
  Priority 150 (configured 150)
  IP redundancy name is "hsrp-Fa0/0-1" (default)

to make sure the active standby go back to the primary everytime it’s come back alive again, configure as below
R1(config)#int fa 0/0
R1(config-if)#standby 1 preempt
use all the method that we already discuss above to verify all the configuration are running as it should

tune hello and holdtime, Cisco recommended to set the value of holdtime three time more than hello time
R1(config)#int fa 0/0
R1(config-if)#standby 1 timers 1 3
set the same on R2 Int Fa 0/0

verify this by continuous ping then shutdown 10.1.1.1, you’ll see shorter down time
Sending 99999, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!..!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!.
Success rate is 97 percent (97/100), round-trip min/avg/max = 12/58/104 ms

Tuesday, March 30, 2010

Routing Between VLANs with SVI and switch L3 routed port



before we go into the SW1 and configure SVI and routed port, let’s prepare the R1 and R2 first
configure addressing for R1 interfaces, and enable routing protocol

R1(config)#interface fastEthernet 0/0
R1(config-if)#ip add 10.0.0.2 255.255.255.0
R1(config-if)#no shut
R1(config-if)#int lo 0
R1(config-if)#ip add 10.1.1.1 255.255.255.255

R1(config)#router eigrp 1
R1(config-router)#no auto-summary
R1(config-router)#net 0.0.0.0


verify all interfaces are advertised by EIGRP, do the same to check on R2 later

R1(config-router)#do sh ip ei int
IP-EIGRP interfaces for process 1
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Fa0/0              0        0/0         0       0/1            0           0
Lo0                0        0/0         0       0/1            0           0


configure R2

R2(config)#int fastEthernet 0/0
R2(config-if)#ip add 172.16.0.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#int fa 0/1
R2(config-if)#ip add 192.168.0.99 255.255.255.0
R2(config-if)#no shut

R2(config)#router eigrp 1
R2(config-router)#no auto-summary
R2(config-router)#network 0.0.0.0



now let’s get to our main topic, routing on switch using Switch Virtual Interface and enabling routing on layer 2 switchport by converting it to layer 3 routed port.
first we need to enable routing on SW1

SW1(config)#ip routing


create VLAN 10 and assign access port to it

SW1(config)#vlan 10
SW1(config-vlan)#name LAB

SW1(config)#int gi 0/47
SW1(config-if)#switchport mode access
SW1(config-if)#switchport access vlan 10


configure EIGRP

SW1(config)#router eigrp 1
SW1(config-router)#no auto-summary
SW1(config-router)#net 0.0.0.0


create VSI for VLAN 10

SW1(config)#interface vlan 10
SW1(config-if)#ip add 10.0.0.1 255.255.255.0

 

now SW1 should be able to route any traffic coming from access port VLAN 10 to other VLAN or network and vice versa. verify this

SW1#sh ip route

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.0.0 is directly connected, GigabitEthernet0/48
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.0.0.0/24 is directly connected, Vlan10
D       10.1.1.1/32 [90/130816] via 10.0.0.2, 00:51:28, Vlan10
D    192.168.0.0/24 [90/30720] via 172.16.0.2, 00:23:12, GigabitEthernet0/48


for the other side, on interface that connected to R2, we’ll change the switchport into a layer 3 routed port, only using one command ‘no switchport’

SW1(config)#interface gi 0/48
SW1(config-if)#no switchport
SW1(config-if)#ip add 172.16.0.1 255.255.255.0
SW1(config-if)#no shut


verify this by ping from pc to loopback 0, ping success, meaning both our SVI and L3 routed port are working correctly.

Pinging 10.1.1.1 with 32 bytes of data:
Reply from 10.1.1.1: bytes=32 time=9ms TTL=253
Reply from 10.1.1.1: bytes=32 time=1ms TTL=253
Reply from 10.1.1.1: bytes=32 time=1ms TTL=253
Reply from 10.1.1.1: bytes=32 time=1ms TTL=253

C:\Windows\System32>tracert 10.1.1.1
Tracing route to 10.1.1.1 over a maximum of 30 hops
  1     5 ms    <1 ms    <1 ms  192.168.0.99
  2     2 ms     4 ms     4 ms  172.16.0.1
  3     2 ms     1 ms     1 ms  10.1.1.1

Wednesday, March 24, 2010

EtherChannel, Trunking, VTP, VLANs and Access port - GNS3 and VPCs

mentor_vlan



























we'll start with setup EtherChannel between S1 and S2
use the range for of the interface for easy setup
S1(config)#interface rang fa 1/14 - 15
S1(config-if-range)#channel-group 1 mode on

Creating a port-channel interface Port-channel1
*Mar  1 00:23:53.623: %EC-5-BUNDLE: Interface Fa1/14 joined port-channel Po1
*Mar  1 00:23:53.683: %EC-5-BUNDLE: Interface Fa1/15 joined port-channel Po1
*Mar  1 00:23:56.579: %LINEPROTO-5-UPDOW
we getting this feedback on the screen, indicating that this EtherChannel is up.
we have created a virtual interface of EtherChannel called Port-Channel1, or Po1
let's verify this by show etherchannel summary, here you can more detail such as interfaces that intercipated in this group
S2#show etherchannel summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        R - Layer3      S - Layer2
        U - in use
Group Port-channel  Ports
-----+------------+-----------------------------------------------------------
1     Po1(SU)     Fa1/14(P)  Fa1/15(P)
now our EtherChannel are ready, let's create a trunk across this EtherChannel to carry the VLAN between both switches.
first we'll define the format or encapsulation of trunk, we are using dot1q
then we configure the mode of the port/interface to be in trunk mode
S1(config)#interface port-channel 1
S1(config-if)#switchport trunk encapsulation dot1q
S1(config-if)#switchport mode trunk
conf on SW2 also
now let's verify we do have our trunk setup
S2#show interfaces trunk
Port      Mode         Encapsulation  Status        Native vlan
Po1       on           802.1q         trunking      1
Port      Vlans allowed on trunk
Po1       1-1005
Port      Vlans allowed and active in management domain
Po1       1
Port      Vlans in spanning tree forwarding state and not pruned
Po1       1
now that we have trunk, next we create VTP Domain to centralize the VLANs management.
to make sure each switch can exchange the VLAN database, the VTP domain name must be the same, we'll also add password to it for more security
SW1 will be the server, while SW2 are the client, every VLAN created in server will advertised to the client.
S1#vlan database
S1(vlan)#vtp domain lab
Changing VTP domain name from NULL to lab
S1(vlan)#vtp server
S1(vlan)#vtp password cisco
Setting device VLAN database password to cisco.
S1(vlan)#
S2(vlan)#vtp domain lab
S2(vlan)#vtp client
Setting device to VTP CLIENT mode.
S2(vlan)#vtp password cisco
Setting device VLAN database password to cisco.
S2(vlan)#
now let's create a few VLAN on VTP server to see is it successfully propagated accross the trunk
S1(vlan)#vlan 10 name IT
VLAN 10 modified:
    Name: IT
S1(vlan)#vlan 20 name Eng
VLAN 20 added:
    Name: Eng
show vlan-switch to make sure it's created an exist on both SW1 and Sw2
S1#show vlan-switch
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0, Fa1/1, Fa1/2, Fa1/3
                                                Fa1/4, Fa1/5, Fa1/6, Fa1/7
                                                Fa1/8, Fa1/9, Fa1/10, Fa1/11
                                                Fa1/12, Fa1/13
10   IT                               active
20   Eng                              active
...
S2#show vlan-switch
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0, Fa1/1, Fa1/2, Fa1/3
                                                Fa1/4, Fa1/5, Fa1/6, Fa1/7
                                                Fa1/8, Fa1/9, Fa1/10, Fa1/11
                                                Fa1/12, Fa1/13
10   IT                               active
20   Eng                              active
yes, now we are confimed that SW2 learn all the VLANs from SW1.
ok, now we'll configure the access port for IT and Eng
S1(config)#interface fastEthernet 1/0
S1(config-if)#switchport access vlan 10
S1(config)#interface fastEthernet 1/1
S1(config-if)#switchport access vlan 20
S2(config)#interface fastEthernet 1/0
S2(config-if)#switchport access vlan 10
S2(config)#interface fastEthernet 1/1
S2(config-if)#switchport access vlan 20
make sure all those port are fall into their right VLAN accordingly, use show vlan-switch
S2#show vlan-switch
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/2, Fa1/3, Fa1/4, Fa1/5
                                                Fa1/6, Fa1/7, Fa1/8, Fa1/9
                                                Fa1/10, Fa1/11, Fa1/12, Fa1/13
10   IT                               active    Fa1/0
20   Eng                              active    Fa1/1
now it's time to test the connectivity, IT pc should be able to access IT server, so do the Eng
configure ip address on VPCS as below (just put any address for the gateway, we don't need it yet because in this lab we don't do routing between different VLAN)
IT pc : 192.168.10.1
Eng pc : 192.168.20.1
IT server : 192.168.10.100
Eng server : 192.168.20.100
VPCS 1 >ip 192.168.10.1 192.168.10.99 24
PC1 : 192.168.10.1 255.255.255.0 gateway 192.168.10.99
VPCS 1 >2
VPCS 2 >ip 192.168.20.1 192.168.20.99 24
PC2 : 192.168.20.1 255.255.255.0 gateway 192.168.20.99
VPCS 2 >3
VPCS 3 >ip 192.168.10.100 192.168.10.99 24
PC3 : 192.168.10.100 255.255.255.0 gateway 192.168.10.99
VPCS 3 >4
VPCS 4 >ip 192.168.20.100 192.168.20.99 24
PC4 : 192.168.20.100 255.255.255.0 gateway 192.168.20.99
make sure all machine in the same VLAN can ping to each other
VPCS 1 >ping 192.168.10.100
192.168.10.100 icmp_seq=1 time=47.804 ms
192.168.10.100 icmp_seq=2 time=27.366 ms
192.168.10.100 icmp_seq=3 time=11.526 ms
192.168.10.100 icmp_seq=4 time=15.531 ms
192.168.10.100 icmp_seq=5 time=21.648 ms
VPCS 2 >ping 192.168.20.100
192.168.20.100 icmp_seq=1 time=40.551 ms
192.168.20.100 icmp_seq=2 time=16.720 ms
192.168.20.100 icmp_seq=3 time=34.366 ms
192.168.20.100 icmp_seq=4 time=16.558 ms
192.168.20.100 icmp_seq=5 time=49.387 ms
if you try to ping to another VLAN, should receive this error because we don't configure any inter-VLAN routing
VPCS 1 >ping 192.168.20.1
host (192.168.10.99) not reachable

Tuesday, March 23, 2010

multicast lab - GNS3


setup the lab as below, bear in mind that multicast is depend on the routing table, so make sure all network are reachable to each other.

enable the multicast routing on both router, R1 and R2

R1(config)#ip multicast-routing

configure PIM on the interfaces R1 : fa0/0 and ser0/0 and R2 fa0/0 and ser0/0


R1
interface FastEthernet0/0
 ip address 192.168.1.99 255.255.255.0
 ip pim sparse-dense-mode
 duplex auto
 speed auto
end
interface Serial0/0
 ip address 10.1.1.1 255.255.255.252
 ip pim sparse-dense-mode
 clock rate 56000
end

R2
interface FastEthernet0/0
 ip address 172.16.1.99 255.255.255.0
 ip pim sparse-dense-mode
 duplex auto
 speed auto
end
interface Serial0/0
 ip address 10.1.1.2 255.255.255.252
 ip pim sparse-dense-mode
end

this is it !! now our multicast traffic should run smoothly on our network. But how to test, there's a few method out there, but let's try this way first.

we'll generate multicast 224.1.1.1 on Source, and interface on Receiver will catch this.

Source

ip sla monitor 1
 type udpEcho dest-ipaddr 224.1.1.1 dest-port 12001 source-ipaddr 192.168.1.10 control disable
 timeout 0
 frequency 5
ip sla monitor schedule 1 start-time now

Receiver

interface FastEthernet1/0
 no switchport
 ip address 172.16.1.10 255.255.255.0
 ip igmp join-group 224.1.1.1
end

Source will generate multicast traffic 224.1.1.1 and start to multicast to the network, any interface that join 224.1.1.1 will grab this packet.

run debug on R1 and R2 to see this packet

R1#debug ip mpacket

focus on the highlighted line, you can see the source of the packet, and to which interface it'll be forwarded. There's another instant of multicast if you notice, that is because i try another method, but.. still working on that ;)
R1
*Mar  1 01:12:59.975: IP(0): s=172.16.1.10 (Serial0/0) d=224.0.1.111 (FastEthernet0/0) id=339, prot=17, len=120(120), mforward
*Mar  1 01:14:59.427: IP(0): s=192.168.1.10 (FastEthernet0/0) d=239.1.1.1 (Serial0/0) id=6548, prot=17, len=44(44), mforward
*Mar  1 01:18:03.727: IP(0): s=192.168.1.10 (FastEthernet0/0) d=239.1.1.1 (Serial0/0) id=8407, prot=17, len=44(44), mforward
*Mar  1 01:23:59.031: IP(0): s=192.168.1.10 (FastEthernet0/0) d=239.1.1.1 (Serial0/0) id=8511, prot=17, len=44(44), mforward
*Mar  1 01:24:59.651: IP(0): s=172.16.1.10 (Serial0/0) d=224.0.1.111 (FastEthernet0/0) id=441, prot=17, len=120(120), mforward

R2
*Mar  1 01:11:55.651: IP(0): s=192.168.1.10 (Serial0/0) d=239.1.1.1 (FastEthernet0/0) id=4729, prot=17, len=44(44), mforward
*Mar  1 01:12:56.051: IP(0): s=172.16.1.10 (FastEthernet0/0) d=224.0.1.111 (Serial0/0) id=339, prot=17, len=120(120), mforward
*Mar  1 01:14:59.503: IP(0): s=192.168.1.10 (Serial0/0) d=239.1.1.1 (FastEthernet0/0) id=6590, prot=17, len=44(44), mforward
*Mar  1 01:23:53.903: IP(0): s=192.168.1.10 (Serial0/0) d=239.1.1.1 (FastEthernet0/0) id=8511, prot=17, len=44(44), mforward
*Mar  1 01:24:54.567: IP(0): s=172.16.1.10 (FastEthernet0/0) d=224.0.1.111 (Serial0/0) id=441, prot=17, len=120(120), mforward

To check the routing and path for multicast, run show ip mroute, there's more detail you can check here

R2#sh ip mroute
..
(*, 224.1.1.1), 02:10:47/00:02:13, RP 0.0.0.0, flags: DC
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet0/0, Forward/Sparse-Dense, 02:09:46/00:00:00
    Serial0/0, Forward/Sparse-Dense, 02:10:47/00:00:00

(*, 224.0.1.40), 02:18:14/00:02:05, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial0/0, Forward/Sparse-Dense, 02:17:05/00:00:00
    FastEthernet0/0, Forward/Sparse-Dense, 02:17:46/00:00:00

(*, 224.0.1.111), 01:48:01/00:02:14, RP 0.0.0.0, flags: DC
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial0/0, Forward/Sparse-Dense, 01:48:01/00:00:00
    FastEthernet0/0, Forward/Sparse-Dense, 01:48:01/00:00:00

Tuesday, March 9, 2010

InterVlan routing - EtherChannel trunking between Switch and 7200 Router - GNS3

as usual, i'll use 3660 with slot NM-16ESW to replace switch



create new vlan 100. now we have 2 vlan include native vlan 1

SW1#vlan database
SW1(vlan)#vlan 100
VLAN 100 added:
    Name: VLAN0100


configure a few ports to be in Vlan 100, int this example port 1/5, 1/6 and 1/7

SW1#conf t
SW1(config)#int ra fa 1/5 - 7
SW1(config-if-range)#switc acce vlan 100
SW1(config-if-range)#exi
SW1(config)#


configure management interface for telnet

SW1(config)#int vlan 1
SW1(config-if)#ip add 10.10.1.1 255.255.255.0
SW1(config-if)#no shut
SW1(config-if)#
*Mar  1 00:21:23.243: %LINK-3-UPDOWN: Interface Vlan1, changed state to up // int is up


configure default gateway, to make sure we can access the switch from any VLan
use the IP of the subinterface on the 7200 for Vlan 1

SW1(config)#ip default-gateway 10.10.1.99


now let's get back to our main course, configuring the EtherChannel
1st, create a logical channel(EtherChannel) interface and enable trunking on it

SW1(config)#int port-channel 1 //this port only up after physical port assign to it
SW1(config-if)#switchport mode trunk
SW1(config-if)#ex


assign ports to port-channel 1

SW1(config)#int ra fa 1/0 - 1
SW1(config-if-range)#channel-group 1 mode on

should receive above message
*Mar  1 00:03:55.619: %EC-5-BUNDLE: Interface Fa1/0 joined port-channel Po1
*Mar  1 00:03:55.659: %EC-5-BUNDLE: Interface Fa1/1 joined port-channel Po1
*Mar  1 00:03:57.535: %LINK-5-CHANGED: Interface Port-channel1, changed state to administratively down
*Mar  1 00:03:58.567: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up



Router 7200 Conf

create EtherChannel and assign port to it

7200(config)#interface port-channel 1

7200(config)#interface fastEthernet 0/1
7200(config-if)#channel-group 1
7200(config-if)#no shut
7200(config-if)#int fa 0/0
7200(config-if)#channel-group 1
7200(config-if)#no shut


create and configure IP address for subinterface over port channel on Vlan 1 and 100


7200(config)#interface port-channel 1.1

7200(config-subif)#encapsulation dot1Q 1 native
7200(config-subif)#ip add 10.10.1.99 255.255.255.0
7200(config-subif)#ex
7200(config)#interface port-channel 1.100
7200(config-subif)#encapsulation dot1Q 100
7200(config-subif)#ip add 10.10.100.99 255.255.255.0

--------------------------------------------------------
a few important show command to check the configuration

SW1#show etherchannel 1 detail
Group state = L2
Ports: 2   Maxports = 8
Port-channels: 1 Max Port-channels = 1
                Ports in the group:
                -------------------
Port: Fa1/0
------------

Port state    = Up Mstr In-Bndl
Channel group = 1           Mode = On/FEC     Gcchange = 0
Port-channel  = Po1         GC   = 0x00010001    Pseudo port-channel = Po1
Port index    = 1
Age of the port in the current state: 00d:00h:44m:37s
Port: Fa1/1
------------

Port state    = Up Mstr In-Bndl
Channel group = 1           Mode = On/FEC     Gcchange = 0
Port-channel  = Po1         GC   = 0x00010001    Pseudo port-channel = Po1
Port index    = 0
Age of the port in the current state: 00d:00h:44m:37s
                Port-channels in the group:
                ----------------------

Port-channel: Po1
------------

Age of the Port-channel   = 00d:00h:49m:18s
Logical slot/port   = 8/0           Number of ports = 2
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse

Ports in the Port-channel:

Index   Port   EC state
------+------+------------
  1     Fa1/0    on
  0     Fa1/1    on

Time since last port bundled:    00d:00h:44m:38s    Fa1/0
Time since last port Un-bundled: 00d:00h:44m:38s    Fa1/1


SW1#show interfaces port-channel 1
Port-channel1 is up, line protocol is up
  Hardware is EtherChannel, address is cc05.1228.f101 (bia cc05.1228.f101)
  MTU 1500 bytes, BW 200000 Kbit/sec, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s
  Members in this channel: Fa1/0 Fa1/1
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

SW1#show interfaces port-channel 1 switchport
Name: Po1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,100
Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none


7200#show interfaces port-channel 1
Port-channel1 is up, line protocol is up
  Hardware is FEChannel, address is ca04.1228.0006 (bia 0000.0000.0000)
  MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
    No. of active members in this channel: 2
        Member 0 : FastEthernet0/1 , Full-duplex, 100Mb/s
        Member 1 : FastEthernet0/0 , Full-duplex, 100Mb/s
  Last input 00:00:00, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/150/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/80 (size/max)
  5 minute input rate 0 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     3607 packets input, 221536 bytes
     Received 4208 broadcasts, 0 runts, 0 giants, 1 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     4 packets output, 308 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

7200#show interfaces port-channel 1.1
Port-channel1.1 is up, line protocol is up
  Hardware is FEChannel, address is ca04.1228.0006 (bia 0000.0000.0000)
  Internet address is 10.10.1.99/24
  MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  1.
  ARP type: ARPA, ARP Timeout 04:00:00
7200#show interfaces port-channel 1.100
Port-channel1.100 is up, line protocol is up
  Hardware is FEChannel, address is ca04.1228.0006 (bia 0000.0000.0000)
  Internet address is 10.10.100.99/24
  MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  100.
  ARP type: ARPA, ARP Timeout 04:00:00