Pages

Tuesday, March 9, 2010

InterVlan routing - EtherChannel trunking between Switch and 7200 Router - GNS3

as usual, i'll use 3660 with slot NM-16ESW to replace switch



create new vlan 100. now we have 2 vlan include native vlan 1

SW1#vlan database
SW1(vlan)#vlan 100
VLAN 100 added:
    Name: VLAN0100


configure a few ports to be in Vlan 100, int this example port 1/5, 1/6 and 1/7

SW1#conf t
SW1(config)#int ra fa 1/5 - 7
SW1(config-if-range)#switc acce vlan 100
SW1(config-if-range)#exi
SW1(config)#


configure management interface for telnet

SW1(config)#int vlan 1
SW1(config-if)#ip add 10.10.1.1 255.255.255.0
SW1(config-if)#no shut
SW1(config-if)#
*Mar  1 00:21:23.243: %LINK-3-UPDOWN: Interface Vlan1, changed state to up // int is up


configure default gateway, to make sure we can access the switch from any VLan
use the IP of the subinterface on the 7200 for Vlan 1

SW1(config)#ip default-gateway 10.10.1.99


now let's get back to our main course, configuring the EtherChannel
1st, create a logical channel(EtherChannel) interface and enable trunking on it

SW1(config)#int port-channel 1 //this port only up after physical port assign to it
SW1(config-if)#switchport mode trunk
SW1(config-if)#ex


assign ports to port-channel 1

SW1(config)#int ra fa 1/0 - 1
SW1(config-if-range)#channel-group 1 mode on

should receive above message
*Mar  1 00:03:55.619: %EC-5-BUNDLE: Interface Fa1/0 joined port-channel Po1
*Mar  1 00:03:55.659: %EC-5-BUNDLE: Interface Fa1/1 joined port-channel Po1
*Mar  1 00:03:57.535: %LINK-5-CHANGED: Interface Port-channel1, changed state to administratively down
*Mar  1 00:03:58.567: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up



Router 7200 Conf

create EtherChannel and assign port to it

7200(config)#interface port-channel 1

7200(config)#interface fastEthernet 0/1
7200(config-if)#channel-group 1
7200(config-if)#no shut
7200(config-if)#int fa 0/0
7200(config-if)#channel-group 1
7200(config-if)#no shut


create and configure IP address for subinterface over port channel on Vlan 1 and 100


7200(config)#interface port-channel 1.1

7200(config-subif)#encapsulation dot1Q 1 native
7200(config-subif)#ip add 10.10.1.99 255.255.255.0
7200(config-subif)#ex
7200(config)#interface port-channel 1.100
7200(config-subif)#encapsulation dot1Q 100
7200(config-subif)#ip add 10.10.100.99 255.255.255.0

--------------------------------------------------------
a few important show command to check the configuration

SW1#show etherchannel 1 detail
Group state = L2
Ports: 2   Maxports = 8
Port-channels: 1 Max Port-channels = 1
                Ports in the group:
                -------------------
Port: Fa1/0
------------

Port state    = Up Mstr In-Bndl
Channel group = 1           Mode = On/FEC     Gcchange = 0
Port-channel  = Po1         GC   = 0x00010001    Pseudo port-channel = Po1
Port index    = 1
Age of the port in the current state: 00d:00h:44m:37s
Port: Fa1/1
------------

Port state    = Up Mstr In-Bndl
Channel group = 1           Mode = On/FEC     Gcchange = 0
Port-channel  = Po1         GC   = 0x00010001    Pseudo port-channel = Po1
Port index    = 0
Age of the port in the current state: 00d:00h:44m:37s
                Port-channels in the group:
                ----------------------

Port-channel: Po1
------------

Age of the Port-channel   = 00d:00h:49m:18s
Logical slot/port   = 8/0           Number of ports = 2
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse

Ports in the Port-channel:

Index   Port   EC state
------+------+------------
  1     Fa1/0    on
  0     Fa1/1    on

Time since last port bundled:    00d:00h:44m:38s    Fa1/0
Time since last port Un-bundled: 00d:00h:44m:38s    Fa1/1


SW1#show interfaces port-channel 1
Port-channel1 is up, line protocol is up
  Hardware is EtherChannel, address is cc05.1228.f101 (bia cc05.1228.f101)
  MTU 1500 bytes, BW 200000 Kbit/sec, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s
  Members in this channel: Fa1/0 Fa1/1
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

SW1#show interfaces port-channel 1 switchport
Name: Po1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,100
Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none


7200#show interfaces port-channel 1
Port-channel1 is up, line protocol is up
  Hardware is FEChannel, address is ca04.1228.0006 (bia 0000.0000.0000)
  MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
    No. of active members in this channel: 2
        Member 0 : FastEthernet0/1 , Full-duplex, 100Mb/s
        Member 1 : FastEthernet0/0 , Full-duplex, 100Mb/s
  Last input 00:00:00, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/150/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/80 (size/max)
  5 minute input rate 0 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     3607 packets input, 221536 bytes
     Received 4208 broadcasts, 0 runts, 0 giants, 1 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     4 packets output, 308 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

7200#show interfaces port-channel 1.1
Port-channel1.1 is up, line protocol is up
  Hardware is FEChannel, address is ca04.1228.0006 (bia 0000.0000.0000)
  Internet address is 10.10.1.99/24
  MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  1.
  ARP type: ARPA, ARP Timeout 04:00:00
7200#show interfaces port-channel 1.100
Port-channel1.100 is up, line protocol is up
  Hardware is FEChannel, address is ca04.1228.0006 (bia 0000.0000.0000)
  Internet address is 10.10.100.99/24
  MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  100.
  ARP type: ARPA, ARP Timeout 04:00:00



show run conf SW1

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SW1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
interface Port-channel1
 switchport mode trunk
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet1/1
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
 switchport access vlan 100
!
interface FastEthernet1/6
 switchport access vlan 100
!
interface FastEthernet1/7
 switchport access vlan 100
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
 ip address 10.10.1.1 255.255.255.0
!
ip default-gateway 10.10.1.99
ip http server
ip forward-protocol nd
!
control-plane
!
line con 0
line aux 0
line vty 0 4
 login
!
end



show run conf 7200

version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 7200
!
ip subnet-zero
!
ip cef
!
call rsvp-sync
!
interface Port-channel1
 no ip address
 hold-queue 150 in
!
interface Port-channel1.1
 encapsulation dot1Q 1 native
 ip address 10.10.1.99 255.255.255.0
!
interface Port-channel1.100
 encapsulation dot1Q 100
 ip address 10.10.100.99 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 channel-group 1
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 channel-group 1
!
ip classless
no ip http server
!
dial-peer cor custom
!
gatekeeper
 shutdown
!
!
line con 0
line aux 0
line vty 0 4
!
end


done !! ce ya on the next post, i got game to watch, Arsenal V Porto ;)

2 comments:

  1. nice one bro, Thanks but i really needs to get ios for L3 switch so i can set up my labs on GNS3 and its really borthering me , I use packet tracer for my lab and i get some weird result and also it often crashs.

    Thank you and more grease to your elbow

    ReplyDelete
  2. will the config be the same if a layer 3 switch were involved instead of a router?

    ReplyDelete