HQ LAN will use OSPF area 1. Once the configuration is done, other branch routers should be able to reach HQ LAN.
hq-rtra#
router ospf 1
log-adjacency-changes
network 10.1.1.0 0.0.0.255 area 1
network 10.9.9.1 0.0.0.0 area 0
network 70.0.0.1 0.0.0.0 area 0
hq-core01#sh run | be router
router ospf 1
log-adjacency-changes
network 10.1.1.0 0.0.0.255 area 1
network 10.1.3.98 0.0.0.0 area 1
network 10.1.11.0 0.0.0.255 area 1
network 10.1.12.0 0.0.0.255 area 1
network 10.1.13.0 0.0.0.255 area 1
network 10.1.14.0 0.0.0.255 area 1
network 10.1.15.0 0.0.0.255 area 1
hq-core02#sh run | be router
router ospf 1
log-adjacency-changes
network 10.1.1.0 0.0.0.255 area 1
network 10.1.11.0 0.0.0.255 area 1
network 10.1.12.0 0.0.0.255 area 1
network 10.1.13.0 0.0.0.255 area 1
network 10.1.14.0 0.0.0.255 area 1
network 10.1.15.0 0.0.0.255 area 1
hq-inet#
router ospf 1
log-adjacency-changes
network 10.1.3.0 0.0.0.255 area 1
Below are couple of useful command to check on connectivity.
ping
traceroute
show ip route
show ip route ospf
show ip route a.b.c.d
The Net
packet packet packet
Thursday, June 27, 2013
Tuesday, June 25, 2013
Routes Lab 01 - HQ LAN address config
sooo.. before we proceed to make HQ LAN available over the WAN to other branch, make sure you have below config ready. There'll be a couple of changes from the original plan, I've decided to use Vlan interface rather than Loopback for Core01/02. After all config applied, make sure all point to point are ping-able.
Hq-rtra
interface Loopback0
ip address 10.9.9.1 255.255.255.255
!
interface
FastEthernet0/0
ip address 10.1.1.1 255.255.255.0
interface Serial0/1
ip address 70.0.0.1 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
clock rate 2000000
frame-relay map ip 70.0.0.2 102 broadcast
frame-relay map ip 70.0.0.3 103 broadcast
no frame-relay inverse-arp
router ospf 1
log-adjacency-changes
network 10.9.9.1 0.0.0.0 area 0
network 70.0.0.1 0.0.0.0 area 0
Hq-rtrb
interface
FastEthernet0/0
ip address 10.1.2.1 255.255.255.0
Hq-core01
interface
FastEthernet0/0
ip address 10.1.1.2 255.255.255.0
interface
FastEthernet1/0
switchport mode trunk
interface
FastEthernet1/15
switchport access vlan 99
!
interface Vlan1
ip address 10.1.11.1 255.255.255.0
!
interface Vlan2
ip address 10.1.12.1 255.255.255.0
!
interface Vlan3
ip address 10.1.13.1 255.255.255.0
!
interface Vlan4
ip address 10.1.14.1 255.255.255.0
!
interface Vlan5
ip address 10.1.15.1 255.255.255.0
!
interface Vlan99
ip address 10.1.3.98 255.255.255.0
because vlan config is not shows up in the runnning config, so I have to show you the actual config that I put in
hq-core01#vlan data
hq-core01(vlan)#vlan
1
VLAN 1 modified:
hq-core01(vlan)#vlan
2
VLAN 2 added:
Name: VLAN0002
hq-core01(vlan)#vlan
3
VLAN 3 added:
Name: VLAN0003
hq-core01(vlan)#vlan
4
VLAN 4 added:
Name: VLAN0004
hq-core01(vlan)#vlan
5
VLAN 5 added:
Name: VLAN0005
hq-core01(vlan)#exit
APPLY completed.
Exiting....
Hq-core2
interface
FastEthernet0/0
ip address 10.1.2.2 255.255.255.0
interface
FastEthernet1/0
switchport mode trunk
interface Vlan1
ip address 10.1.11.2 255.255.255.0
!
interface Vlan2
ip address 10.1.12.2 255.255.255.0
!
interface Vlan3
ip address 10.1.13.2 255.255.255.0
!
interface Vlan4
ip address 10.1.14.2 255.255.255.0
!
interface Vlan5
ip address 10.1.15.2 255.255.255.0
hq-core02#vlan data
hq-core02(vlan)#vlan
1
VLAN 1 modified:
hq-core02(vlan)#vlan
2
VLAN 2 added:
Name: VLAN0002
hq-core02(vlan)#vlan
3
VLAN 3 added:
Name: VLAN0003
hq-core02(vlan)#vlan
4
VLAN 4 added:
Name: VLAN0004
hq-core02(vlan)#vlan
5
VLAN 5 added:
Name: VLAN0005
hq-core02(vlan)#exit
APPLY completed.
Exiting....
Hq-inet
interface Loopback0
ip address 200.1.1.1 255.255.255.0
!
interface
FastEthernet0/0
ip address 10.1.3.99 255.255.255.0
all ping-able and looks good ? later we start to advertise HQ LAN over the WAN
Thursday, June 20, 2013
Routes Lab 01 - WAN OSPF area 0
We could use a few
type of frame-relay network (NBMA or point-to-multipoint). Let's go with
point-to-multipoint, it's like a collection of point-to-point network from each
sites. This is not going to be a Hub and Spokes network because each site have
it's own DLCI to others. So it's a full mesh network.
Add below command on
all WAN interfaces to make a point-to-multipoint Frame-relay network.
interface Serial0/1
ip ospf network point-to-multipoint
configure OSPF area
0 for the WAN interfaces and Loopbacks, do the same for the rest of the Net
router ospf 1
log-adjacency-changes
network 10.9.9.1 0.0.0.0 area 0
network 70.0.0.1 0.0.0.0 area 0
make sure neighbor are formed between the three WAN routers. below are a few useful command to get some information and troubleshoot.
show ip route
show ip route ospf
sh ip ospf interface serial 0/1
show ip protocols
show ip ospf
show ip ospf neighbor
next we will configure routing on the LAN using EIGRP and redistribute it to the OSPF so that the other side of the network can reach it.
Wednesday, June 19, 2013
Routes Lab 01 - Basic Frame-Relay
set the DLCI for NetA Frame-Relay switch as below
configure the Routers IP as below, make sure they can ping to each other IP address.
hq-rtra#
interface Serial0/1
ip address 70.0.0.1 255.255.255.0
encapsulation frame-relay
clock rate 2000000
frame-relay map ip 70.0.0.2 102 broadcast
frame-relay map ip 70.0.0.3 103 broadcast
no frame-relay inverse-arp
End
moon-rtra#
interface Serial0/1
ip address 70.0.0.2 255.255.255.0
encapsulation frame-relay
clock rate 2000000
frame-relay map ip 70.0.0.1 201 broadcast
frame-relay map ip 70.0.0.3 203 broadcast
no frame-relay inverse-arp
End
mars-rtra#
interface Serial0/1
ip address 70.0.0.3 255.255.255.0
encapsulation frame-relay
clock rate 2000000
frame-relay map ip 70.0.0.1 301 broadcast
frame-relay map ip 70.0.0.2 302 broadcast
no frame-relay inverse-arp
end
do the same for the NetB or backup WAN.. once finish test all the connectivity. Next we will start to configure the OSPF for the Frame-Relay
Routes Lab 01
let's start a route lab, I don't really have a specific topic to focus on, but basically we will go thru three main topics related to OSPF, EIGRP and Redistribution (or maybe some others thing that might seems to be a good idea to be included along the way)
In this scenario, we have a HQ and two branch office. All three sites connected via 2 ISP (WAN), NetA for primary and NetB for backup. HQ and Moon sites have their own Internet gateway.
prepare your GNS topology as below diagram with (1) DLCI (2) GNS3 (3) IP scheme details
*please take note that I missed Loopback 0 for all the WAN routers.
rtra hq/moon/mars - 10.9.9.1/2/3 255.255.255.255
rtrb hq/moon/mars - 10.9.9.11/12/13 255.255.255.255
next lab we will start with Frame-relay configuration.
*please take note that first half of the upcoming labs will focus on Primary WAN which is NetA network, we will bring up the backup WAN later..
In this scenario, we have a HQ and two branch office. All three sites connected via 2 ISP (WAN), NetA for primary and NetB for backup. HQ and Moon sites have their own Internet gateway.
prepare your GNS topology as below diagram with (1) DLCI (2) GNS3 (3) IP scheme details
*please take note that I missed Loopback 0 for all the WAN routers.
rtra hq/moon/mars - 10.9.9.1/2/3 255.255.255.255
rtrb hq/moon/mars - 10.9.9.11/12/13 255.255.255.255
next lab we will start with Frame-relay configuration.
*please take note that first half of the upcoming labs will focus on Primary WAN which is NetA network, we will bring up the backup WAN later..
Tuesday, February 12, 2013
OSPF - Routes Filtering
please refer to previous post for details and configuration.
before we get started, please take notes that we can only filter routes from being installed into the router's routing table, that means we can only filter inbound routes.
We'll filter Could 5 (10.10.5.0/24) on R4, so that Cloud 1 & 2 (192.168.1.0 and 192.168.2.0) could not reach Cloud 5.
Before changes, Cloud 1/2 can reach Cloud 5
VPCS[1]> ping 10.10.5.1
10.10.5.1 icmp_seq=1 ttl=61 time=32.803 ms
10.10.5.1 icmp_seq=2 ttl=61 time=39.639 ms
10.10.5.1 icmp_seq=3 ttl=61 time=37.984 ms
10.10.5.1 icmp_seq=4 ttl=61 time=37.612 ms
10.10.5.1 icmp_seq=5 ttl=61 time=34.332 ms
Create access list for the interested route, and apply it on OSPF process 1
access-list 1 deny 10.10.5.0 0.0.0.255
access-list 1 permit any
router ospf 1
..
distribute-list 1 in FastEthernet0/0
VPCS[1]> ping 10.10.5.1
*192.168.1.254 icmp_seq=1 ttl=255 time=19.864 ms (ICMP type:3, code:1, Destination host unreachable)
*192.168.1.254 icmp_seq=2 ttl=255 time=12.023 ms (ICMP type:3, code:1, Destination host unreachable)
*192.168.1.254 icmp_seq=3 ttl=255 time=13.934 ms (ICMP type:3, code:1, Destination host unreachable)
*192.168.1.254 icmp_seq=4 ttl=255 time=6.390 ms (ICMP type:3, code:1, Destination host unreachable)
*192.168.1.254 icmp_seq=5 ttl=255 time=19.270 ms (ICMP type:3, code:1, Destination host unreachable)
Make sure Cloud 6 is accessible by both, and the rest of routes and access is not affected
OSPF Multi Area GNS3 Lab
download [dot]net file and config files for below topology and configuration, next tutorial might be based on this topology
[dot]net topology file
R1 Config
R2 Config
R3 Config
R4 Config
- topology
- vpc
Subscribe to:
Posts (Atom)