Pages

Thursday, January 7, 2010

OSPF and frame relay network

Network Diagram

Configure as below


HQ


interface Loopback1
 ip address 10.1.1.1 255.255.255.0
 ip ospf network point-to-point


interface Serial0/0
 ip address 10.1.123.1 255.255.255.0
 encapsulation frame-relay
 clock rate 2000000
 frame-relay map ip 10.1.123.1 102
 frame-relay map ip 10.1.123.2 102 broadcast
 frame-relay map ip 10.1.123.3 103 broadcast
 no frame-relay inverse-arp






router ospf 1
log-adjacency-changes
network 10.1.1.0 0.0.0.255 area 0
network 10.1.123.0 0.0.0.255 area 0
neighbor 10.1.123.2
neighbor 10.1.123.3




EB


interface Loopback2
 ip address 10.1.2.1 255.255.255.0
 ip ospf network point-to-point


interface FastEthernet0/0
 ip address 10.1.23.2 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.1.123.2 255.255.255.0
 encapsulation frame-relay
 ip ospf priority 0
 clock rate 2000000
 frame-relay map ip 10.1.123.1 201 broadcast
 frame-relay map ip 10.1.123.2 201
 frame-relay map ip 10.1.123.3 201 broadcast
 no frame-relay inverse-arp


router ospf 1
 log-adjacency-changes
 network 10.1.2.0 0.0.0.255 area 0
 network 10.1.123.0 0.0.0.255 area 0

WB

interface Loopback3
 ip address 10.1.3.1 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip address 10.1.23.3 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.1.123.3 255.255.255.0
 encapsulation frame-relay
 ip ospf priority 0
 clock rate 2000000
 frame-relay map ip 10.1.123.1 301 broadcast
 frame-relay map ip 10.1.123.2 301 broadcast
 frame-relay map ip 10.1.123.3 301
 no frame-relay inverse-arp


router ospf 1
 log-adjacency-changes
 network 10.1.3.0 0.0.0.255 area 0
 network 10.1.123.0 0.0.0.255 area 0


let's discuss the configuration highlighted in yellow

neighbor 10.1.123.2
neighbor 10.1.123.3



- frame-relay is non-broadcast network, so they can't automatically form neighbor. so we need to manually add neighbor on HQ

ip ospf priority 0


- in this kind of topology(hub-and-spoke), make sure HQ got to be the DR router for availability purpose, set priority on both branch to be 0



Point-To-Multipoint

but there's another option to configure OSPF in frame-relay, by using Point-To-Multipoint. This configuration didn't elect DR/BDR, so we need to remove neighbor and interface priority from previous setting.

HQ(config-router)#no neighbor 10.1.123.2
HQ(config-router)#no neighbor 10.1.123.3


EB(config-if)#no ip ospf priority 0


WB(config-if)#no ip ospf priority 0

after that issue this command on all 3 serial interface that facing frame-relay

HQ(config)#int ser 0/0
HQ(config-if)#ip ospf network point-to-multipoint

neighbor should build-up now

HQ#sh ip ospf ne
Neighbor ID     Pri   State           Dead Time   Address         Interface
10.1.3.1          0   FULL/  -        00:01:53    10.1.123.3      Serial0/0
10.1.2.1          0   FULL/  -        00:01:50    10.1.123.2      Serial0/0


Changing OSPF timer

now add the ethernet link on both EB and WB into area 0

EB(config-router)#net 10.1.32.2 0.0.0.255 area 0


WB(config-router)#net 10.1.23.3 0.0.0.255 area 0

from show ip ospf interface can see the default value for hello and dead time interval

WB#sh ip os int fa 0/0
FastEthernet0/0 is up, line protocol is up
 ..
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
..

now change to hello = 5, dead 15, this need to be done on both interface

EB(config)#int fa 0/0
EB(config-if)#ip ospf hello-interval 5
EB(config-if)#ip ospf dead-interval 15

now show ip ospf interface again, the result should change
..
  Flush timer for old DR LSA due in 00:02:15
  Timer intervals configured, Hello 5, Dead 15, Wait 15, Retransmit 5
    oob-resync timeout 40
..

download full conf here

Conf HQ
Conf WB
Conf EB

No comments:

Post a Comment