Pages

Wednesday, April 7, 2010

EIGRP over Frame-relay

framerelay_eigrp
EIGRP over frame relay with two spokes and a hub
R1
interface Serial0/0
ip address 10.1.123.1 255.255.255.0
encapsulation frame-relay
clock rate 2000000
frame-relay map ip 10.1.123.1 102
frame-relay map ip 10.1.123.2 102 broadcast
frame-relay map ip 10.1.123.3 103 broadcast
no frame-relay inverse-arp
router eigrp 1
network 0.0.0.0
no auto-summary

R2
interface Serial0/0
ip address 10.1.123.2 255.255.255.0
encapsulation frame-relay
clock rate 2000000
frame-relay map ip 10.1.123.1 201 broadcast
frame-relay map ip 10.1.123.2 201
frame-relay map ip 10.1.123.3 201 broadcast
no frame-relay inverse-arp
router eigrp 1
network 0.0.0.0
no auto-summary

R3
interface Serial0/0
ip address 10.1.123.3 255.255.255.0
encapsulation frame-relay
clock rate 2000000
frame-relay map ip 10.1.123.1 301 broadcast
frame-relay map ip 10.1.123.2 301 broadcast
frame-relay map ip 10.1.123.3 301
no frame-relay inverse-arp
router eigrp 1
network 0.0.0.0
no auto-summary

i still have a problem, EIGRP on spoke(R1 and R2) can’t learn each other.. can anyone help me with this?


now i know why !!

it is because if the split-horizon, it deny the interface from advertise any route out if it learning from it

so, just turn off split-horizon on that interface

 R2(config)#int ser 0/0
R2(config-if)#no ip split-horizon eigrp 1

3 comments:

  1. You configured NBMA network type, so you need to manually configured EIGRP neighbors. Or you can chose to use point-to-point network type using subinterfaces on R1.
    BTW, you wrote excellent and detailed post, thanks for sharing.

    ReplyDelete
  2. Thanks Simon,

    yes i configure NBMA network type, that's why i put 'broadcast' on every frame-relay map command above. so i have no problem to form EIGRP neighbor now

    i suspect this is because of split horizon, but after i turn it off, i still got the same result ..

    any idea?

    ReplyDelete
  3. sorry again, actually i should give the router some time . i got the solution, it is because of the split-horizon

    ReplyDelete