Pages

Tuesday, January 18, 2011

static floating route - gns3

using static route when dynamic route not available

primary link between network 192.168.1.0/24 and 10.1.1.0/24 are thru R3, learn each others via EIGRP . R2 is a backup link in case the primary link is not available

*this is not a complete routing solution, this lab only looking from R1 point of view to reach 10.1.1.0/24

R1
interface Loopback1
ip address 192.168.1.1 255.255.255.0
!
interface Serial0/0
ip address 172.16.2.1 255.255.255.252
clock rate 56000
!
interface Serial0/1
ip address 172.16.1.1 255.255.255.252
clock rate 56000
!
router eigrp 1
network 10.0.0.0
network 172.16.1.0 0.0.0.3
network 192.168.1.0
no auto-summary
!
ip route 10.1.1.0 255.255.255.0 172.16.2.2 190
!

R2
interface FastEthernet0/0
ip address 10.1.1.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 172.16.2.2 255.255.255.252
clock rate 56000
!
ip route 192.168.0.0 255.255.0.0 172.16.2.1

R3
interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 172.16.1.2 255.255.255.252
clock rate 56000
!
router eigrp 1
network 10.1.1.0 0.0.0.255
network 172.16.1.0 0.0.0.3
no auto-summary

-----------------------------------------------------

we've configure two route for R1 to reach 10.1.1.0

router eigrp 1
network 10.0.0.0
..

and

ip route 10.1.1.0 255.255.255.0 172.16.2.2 190

only one route with the lowest AD installed into the routing table
in this case, route from EIGRP (AD=90), static route(AD=190 as we defined)

R1#sh ip route
..

10.0.0.0/24 is subnetted, 1 subnets
D 10.1.1.0 [90/2195456] via 172.16.1.2, 00:05:22, Serial0/1
C 192.168.1.0/24 is directly connected, Loopback1

this what we call floating static route, by default AD for static route is 1, because we want this route to backup primary link w/ EIGRP in case it's not available.. we made it's AD higher than EIGRP AD

shutdown primary link to see the effect..


R1(config)#int ser 0/1
R1(config-if)#shut

R1#sh ip route
..
     10.0.0.0/24 is subnetted, 1 subnets
S       10.1.1.0 [190/0] via 172.16.2.2

new route come into place.. via static with AD 190, thru 172.16.2.2 which is R2

2 comments:

  1. I am confused. Do you need to add the line 'ip route 192.168.1.0 255.255.255.0 10.1.1.2 190' to R3's configuration? If you don't then R3 doesn't know how to get to 192.168.1.0 when EIGRP disappears from its routing table.

    Also I kept EIGRP's 10.1.1.0's network statement the same (BOTH 'network 10.0.0.0') for R1 and R3). Is that OK?

    thanks

    ReplyDelete
  2. Should I use the network statement 'network 10.1.1.0 0.0.0.255' instead of 'network 10.0.0.0 0.255.255.255'?

    Thanks again

    P.S.Sorry I didn't post this in the and my other questions in the same post

    ReplyDelete