Pages

Tuesday, June 1, 2010

Redistribution EIGRP and OSPF - GNS3





check at bottom page for full running configuration

redistribute all route from OSPF area 0 into EIGRP 1
R1(config-router)#redistribute ospf 1

But R2 didn’t any route from OSPF routing table
R2>sh ip rou ei
     1.0.0.0/32 is subnetted, 1 subnets
D       1.1.1.1 [90/156160] via 192.168.1.1, 00:20:32, FastEthernet0/0

This is because we need initiate the seed metric for the learned route, if not redistribution not gonna work
R1(config-router)#redistribute ospf 1 metric 100 1 255 1 1500

R2>sh ip rou ei
     1.0.0.0/32 is subnetted, 1 subnets
D       1.1.1.1 [90/156160] via 192.168.1.1, 00:34:24, FastEthernet0/0
     3.0.0.0/32 is subnetted, 1 subnets
D EX    3.3.3.3 [170/25602816] via 192.168.1.1, 00:01:02, FastEthernet0/0
     172.16.0.0/24 is subnetted, 1 subnets
D EX    172.16.1.0 [170/25602816] via 192.168.1.1, 00:01:02, FastEthernet0/0
     10.0.0.0/32 is subnetted, 1 subnets
D EX    10.1.1.1 [170/25602816] via 192.168.1.1, 00:01:02, FastEthernet0/0

From routing table, there’s route to R3 loopback0, 3.3.3.3
Ping the R3 loopback
R2>p 3.3.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Can’t ping? What happen, let’s try traceroute to see where’s the problem
It’s look like the problem is on R1, the trace stop at R1
R2>traceroute 3.3.3.3

Type escape sequence to abort.
Tracing the route to 3.3.3.3

  1 192.168.1.1 40 msec 36 msec 16 msec
  2  *  *  *

The problem is because we only redistribute route from OSPF into EIGRP, but no in the other way
So R3 loopback don’t know how to return the packet it receive from R2
Redistribute from EIGRP to OSPF
R1(config-router)#redistribute eigrp 1
% Only classful networks will be redistributed

Notice the alert in yellow, let see is the router really meant it.. so in this case R3 should only learn classful; 192.168.1.0/24 only, there’ll no 1.1.1.1/32 and 2.2.2.2/32
R3>sh ip rou os
O E2 192.168.1.0/24 [110/20] via 172.16.1.1, 00:02:20, FastEthernet0/1

Yes, they really meant it
Here is the command to make sure that redistribution happen for both classful and classless
R1(config-router)#redistribute ei 1 subnets

R3>sh ip rou os
     1.0.0.0/32 is subnetted, 1 subnets
O E2    1.1.1.1 [110/20] via 172.16.1.1, 00:00:25, FastEthernet0/1
     2.0.0.0/32 is subnetted, 1 subnets
O E2    2.2.2.2 [110/20] via 172.16.1.1, 00:00:25, FastEthernet0/1
O E2 192.168.1.0/24 [110/20] via 172.16.1.1, 00:00:25, FastEthernet0/1

 click here for full Running Configuration 

4 comments:

  1. Hello How i can redistribute all route from OSPF area NOT 0 into EIGRP 1
    Pleas area not 0 Ex area 2
    Thank you all

    ReplyDelete
  2. Hey Fella,

    Thanks for the article. That really explained what I needed and worked for me

    ReplyDelete
  3. Thanks for the article.. very well explained

    ReplyDelete
  4. Abdul Razzak

    Hi Guys,
    After redistribute eigrp into ospf configuration, i m not able to ping eigrp network
    10.1.1.1 and 1.1.1.1 which on R1 from R3 but i can able see the OE2 routes on R3, this is small topology, Can anyone help me on this?
    R1—R2—R3,

    R1 configuration
    interface Loopback0
    ip address 10.1.1.1 255.255.255.0
    !
    interface FastEthernet0/0
    ip address 1.1.1.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    router eigrp 100
    network 1.0.0.0
    network 10.0.0.0
    no auto-summary
    !

    R2 Configuration
    interface Loopback0
    ip address 20.1.1.1 255.255.255.0
    !
    interface FastEthernet0/0
    ip address 1.1.1.2 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    ip address 2.2.2.1 255.255.255.0
    duplex auto
    speed auto
    !
    router eigrp 100
    network 1.0.0.0
    network 20.0.0.0
    no auto-summary
    !
    router ospf 1
    log-adjacency-changes
    redistribute eigrp 100 metric 10 subnets
    network 2.2.2.1 0.0.0.0 area 0
    !

    R3 Configuration
    interface Loopback0
    ip address 30.1.1.1 255.255.255.0
    !
    interface FastEthernet0/0
    ip address 2.2.2.2 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    router ospf 1
    log-adjacency-changes
    network 2.2.2.2 0.0.0.0 area 0
    network 30.0.0.0 0.255.255.255 area 0
    !

    R3 Routing table
    R3#sh ip route
    Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
    D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
    N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
    E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
    i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
    * – candidate default, U – per-user static route, o – ODR
    P – periodic downloaded static route

    Gateway of last resort is not set

    1.0.0.0/24 is subnetted, 1 subnets
    O E2 1.1.1.0 [110/10] via 2.2.2.1, 00:08:01, FastEthernet0/0
    2.0.0.0/24 is subnetted, 1 subnets
    C 2.2.2.0 is directly connected, FastEthernet0/0
    10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    O E2 10.0.0.0/8 [110/10] via 2.2.2.1, 00:08:01, FastEthernet0/0
    O E2 10.1.1.0/24 [110/10] via 2.2.2.1, 00:08:01, FastEthernet0/0
    20.0.0.0/24 is subnetted, 1 subnets
    O E2 20.1.1.0 [110/10] via 2.2.2.1, 00:08:01, FastEthernet0/0
    30.0.0.0/24 is subnetted, 1 subnets
    C 30.1.1.0 is directly connected, Loopback0

    not able to ping R1 10.1.1.1 and 1.1.1.1 from R3
    R3#ping 10.1.1.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
    …..
    Success rate is 0 percent (0/5)

    R3#ping 1.1.1.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
    …..
    Success rate is 0 percent (0/5)

    ReplyDelete