Initial Configuration
Create 4 VLANs, 10,20,30,40
Trunk between the 3 Switches
or you can follow the configuration from previous lab for the 3 Switches click here
create SVI for VLAN 10 on CORE1 and CORE2
CORE1(config)#int vlan 10
CORE1(config-if)#ip add 10.10.10.1 255.255.255.0
CORE1(config-if)#no shut
CORE2(config)#int vlan 10
CORE2(config-if)#ip add 10.10.10.2 255.255.255.0
CORE2(config-if)#no shut
CORE1(config-if)#ip add 10.10.10.1 255.255.255.0
CORE1(config-if)#no shut
CORE2(config)#int vlan 10
CORE2(config-if)#ip add 10.10.10.2 255.255.255.0
CORE2(config-if)#no shut
configure connectivity between CORE1 and R1
on CORE1 convert L2 into L3 port to assign IP address to it
CORE1(config)#int gi1/48
CORE1(config-if)#no switchport
CORE1(config-if)#ip add 192.168.1.1 255.255.255.252
CORE1(config-if)#no shut
CORE1(config-if)#no switchport
CORE1(config-if)#ip add 192.168.1.1 255.255.255.252
CORE1(config-if)#no shut
R1(config)#int gi0/1
R1(config-if)#ip add 192.168.1.2 255.255.255.252
R1(config-if)#no shut
configure connectivity between CORE2 and R1, CORE2 using SVI
create new VLAN and it's SVI on CORE2 for this connection, assign as access port
CORE2(config)#int gi7/48
CORE2(config-if)#switchport
CORE2(config-if)#switchport mode access
CORE2(config-if)#switchport access vlan 19
CORE2(config)#int vlan 19
CORE2(config-if)#ip add 192.168.2.1 255.255.255.0
CORE2(config-if)#no shut
CORE2(config-if)#ip add 192.168.2.1 255.255.255.0
CORE2(config-if)#no shut
configure Routing on CORE1, CORE2 and R1
HSRP
now we'll create HSRP for VLAN 10
on CORE1
CORE1(config)#int vlan 10
CORE1(config-if)#standby 10 ip 10.10.10.99
on CORE2
CORE2(config)#int vlan 10
CORE2(config-if)#standby 10 ip 10.10.10.99
CORE2(config-if)#standby 10 ip 10.10.10.99
it's that simple, show standby to make sure HSRP is working
CORE1#sh stand
Vlan10 - Group 10
Local state is Active, priority 100 default priority is 100
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 1.732
Virtual IP address is 10.10.10.99 configured
Active router is local this is primary router
Standby router is 10.10.10.2 expires in 8.696 router 10.10.10.2 is standby
Virtual mac address is 0000.0c07.ac0a
2 state changes, last state change 00:01:55
IP redundancy name is "hsrp-Vl10-10" (default)
Vlan10 - Group 10
Local state is Active, priority 100 default priority is 100
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 1.732
Virtual IP address is 10.10.10.99 configured
Active router is local this is primary router
Standby router is 10.10.10.2 expires in 8.696 router 10.10.10.2 is standby
Virtual mac address is 0000.0c07.ac0a
2 state changes, last state change 00:01:55
IP redundancy name is "hsrp-Vl10-10" (default)
CORE2#sh stand
Vlan10 - Group 10
Local state is Standby, priority 100
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 0.506
Virtual IP address is 10.10.10.99 configured
Active router is 10.10.10.1, priority 100 expires in 9.408
Standby router is local
1 state changes, last state change 00:04:06
IP redundancy name is "hsrp-Vl10-10" (default)
Vlan10 - Group 10
Local state is Standby, priority 100
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 0.506
Virtual IP address is 10.10.10.99 configured
Active router is 10.10.10.1, priority 100 expires in 9.408
Standby router is local
1 state changes, last state change 00:04:06
IP redundancy name is "hsrp-Vl10-10" (default)
manipulate priority to control active/standby router, the higher the value, the higher the chance to become an active
we'll make CORE2 (router 10.10.10.2) to be the active
CORE2(config-if)#standby 10 priority 150
Vlan10 - Group 10
Local state is Standby, priority 150 priority already higher
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 1.955
Virtual IP address is 10.10.10.99 configured
Active router is 10.10.10.1, priority 100 expires in 8.748
Standby router is local but this router still on standby, this is because HSRP not 'dynamically' change, add another line to force change base on priority
CORE2(config-if)#standby 10 preempt
immediately you'll see active router change
3d19h: %STANDBY-6-STATECHANGE: Vlan10 Group 10 state Active -> Speak
Manipulating HSRP to load balancing
basically we'll create 2 gateway, and you need to divide your host into two group and each point to one gateway
here I'll just paste the running config
CORE1
interface Vlan10
ip address 10.10.10.1 255.255.255.0
standby 1 ip 10.10.10.10
standby 1 priority 150
standby 1 preempt
standby 2 ip 10.10.10.20
standby 2 preempt
end
CORE2
interface Vlan10
ip address 10.10.10.2 255.255.255.0
standby 1 ip 10.10.10.10
standby 1 preempt
standby 2 ip 10.10.10.20
standby 2 priority 150
standby 2 preempt
end
from show standby you'll see that Group 1 active on CORE1 and Group 2 active on CORE2
CORE1#sh stand
Vlan10 - Group 1
Local state is Active, priority 150, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 1.609
Virtual IP address is 10.10.10.10 configured
Active router is local
Standby router is 10.10.10.2 expires in 9.520
Virtual mac address is 0000.0c07.ac01
2 state changes, last state change 00:09:22
IP redundancy name is "hsrp-Vl10-1" (default)
Vlan10 - Group 2
Local state is Standby, priority 100, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 2.233
Virtual IP address is 10.10.10.20 configured
Active router is 10.10.10.2, priority 150 expires in 8.268
Standby router is local
4 state changes, last state change 00:05:46
IP redundancy name is "hsrp-Vl10-2" (default)
CORE2#sh stand
Vlan10 - Group 1
Local state is Standby, priority 100, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 1.560
Virtual IP address is 10.10.10.10 configured
Active router is 10.10.10.1, priority 150 expires in 7.608
Standby router is local
1 state changes, last state change 00:06:01
IP redundancy name is "hsrp-Vl10-1" (default)
Vlan10 - Group 2
Local state is Active, priority 150, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 0.550
Virtual IP address is 10.10.10.20 configured
Active router is local
Standby router is 10.10.10.1 expires in 8.980
Virtual mac address is 0000.0c07.ac02
4 state changes, last state change 00:06:20
IP redundancy name is "hsrp-Vl10-2" (default)
try shutdown SVI 10 on CORE2
CORE2(config)#int vlan 10
CORE2(config-if)#shut
CORE1 will be the active router for both Group
CORE1#sh stand
Vlan10 - Group 1
Local state is Active, priority 150, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 0.057
Virtual IP address is 10.10.10.10 configured
Active router is local
Standby router is unknown
Virtual mac address is 0000.0c07.ac01
2 state changes, last state change 00:14:45
IP redundancy name is "hsrp-Vl10-1" (default)
Vlan10 - Group 2
Local state is Active, priority 100, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 2.199
Virtual IP address is 10.10.10.20 configured
Active router is local
Standby router is unknown
Virtual mac address is 0000.0c07.ac02
5 state changes, last state change 00:00:18
IP redundancy name is "hsrp-Vl10-2" (default)
Vlan10 - Group 1
Local state is Active, priority 150, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 0.057
Virtual IP address is 10.10.10.10 configured
Active router is local
Standby router is unknown
Virtual mac address is 0000.0c07.ac01
2 state changes, last state change 00:14:45
IP redundancy name is "hsrp-Vl10-1" (default)
Vlan10 - Group 2
Local state is Active, priority 100, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 2.199
Virtual IP address is 10.10.10.20 configured
Active router is local
Standby router is unknown
Virtual mac address is 0000.0c07.ac02
5 state changes, last state change 00:00:18
IP redundancy name is "hsrp-Vl10-2" (default)
but what happen if connection on R1 down, how HSRP gonna detect that? we can use track
on CORE1 we'll keep track port Gi1/48
CORE1(config-if)#stand 1 track gigabitEthernet 1/48
on CORE2, keep track on SVI 10
CORE2(config-if)#stand 2 track vlan 19
shutdown SVI 19 to see the effect, then show standby
CORE2(config)#int vla 19
CORE2(config-if)#shut
CORE2(config-if)#shut
Local state is Active, priority 140 (confgd 150), may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 1.184
Virtual IP address is 10.10.10.20 configured
Active router is local but why this is still local
Standby router is 10.10.10.1 expires in 9.232
Virtual mac address is 0000.0c07.ac02
6 state changes, last state change 00:07:27
IP redundancy name is "hsrp-Vl10-2" (default)
Priority tracking 1 interface or object, 0 up:
Interface or object Decrement State
Vlan19 10 Down (administratively down) because, notice here, decrement only 10, latest value, 140, is still higher than the other side, so make sure the different between this two is no more than 10 to see the right effect
I think you should know where to adjust the priority ;) Happy Switching
What traffic is traversing in between the two core through the links G1/1 & G1/2 of Core01 and that of links G7/1 & G7/2 of Core02?
ReplyDeleteWas that configured as Access or rather as Trunk Ports?
:)
sorry, what software is using for this lab
ReplyDeleteGNS3
DeleteForm and manner of display of registration marks on the motor vehicles as per Central Motor Vehicles rulesAccording to sub-section (6) of section 41,on or after commencement of this rule, the registration mark referred to shall be displayed both at the front, rear and windshield of all vehicles clearly and legibly in the form of security license plate of the following specifications, namely.
ReplyDeletehi... i hav almost same configurations here on 2x 3825... however i noticed the hsrp did work properly but i have alternate packet loss thru icmp ping... y is this so??? can help?
ReplyDeleteHi All .
ReplyDeleteI have doubt when we are configuring HSRP for the L3 VLAN , when will the HSRP state will go down ( with out tracking the Interface ).
Thanks
PREMKB
Premk87@gmail.com
Thank You and I have a super give: What To Expect When Renovating A House home repairs contractors
ReplyDelete